Inscríbete en nuestro Máster Gratuito en Marketing Digital

100% en línea
80+ Horas
Horario Flexible
Con certificado
2M+ Alumnos

Categoría:
Autor: Jorge Rivero
Fecha: 24/06/2022

Funciones lógicas en Excel: Conoce cómo emplearlas correctamente.

Si se trata de tomar decisiones en esta herramienta, las funciones lógicas de Excel son muy utilizadas. ¿Por qué? Éstas, te ayudan a determinar si una acción que hayas establecido se ejecutará o no, es decir, te permite evaluar si en relación al resultado se cumple o no una condición dada.

¿Qué son las funciones lógicas en Excel?

El objetivo de estas funciones es permitir el uso de valores lógicos o evaluar los valores de manera lógica con diferentes propósitos.

Las funciones lógicas permiten el uso de operadores, conocidos también como conectores lógicos, por ejemplo:

“Operador Y” y el “operador O”.

¿Cuáles son las funciones lógicas en Excel?

Te presentamos un listado con todas las funciones lógicas en Excel, lo que hace y representa cada función, así como para emplearla de forma adecuada.

Descripciones y sintaxis de las funciones lógicas en Excel

FUNCIÓN FALSO

DESCRIPCIÓN

SINTAXIS

EJEMPLO

Devuelve el valor lógico FALSO FALSO() FALSO() = FALSO

FUNCIÓN NO

DESCRIPCIÓN SINTAXIS

EJEMPLO

Cambia FALSO por VERDADERO y VERDADERO por FALSO.

 

·         NO(valor_lógico)

·         Valor_lógico (obligatorio): Expresión o Valor a valorar como VERDADERO o FALSO

·         NO(VERDADERO) = FALSO

·         NO(FALSO) = VERDADERO

 

Funciones lógicas en ExcelFUNCIÓN O

DESCRIPCIÓN SINTAXIS

EJEMPLO

Si alguno de los argumentos es VERDADERO lo demuestra y devuelve VERDADERO o FALSO.

Si todos los argumentos son FALSO, restituye FALSO.

 

  • O(valor_lógico1, [valor_lógico2], …)

·         valor_lógico1 (obligatorio): Primera condición a probar.

·         valor_lógico2 (opcional): Probar condiciones adicionales.

·         O(VERDADERO, FALSO) = VERDADERO

·         O(FALSO, FALSO) = FALSO

 

Nota: Las condiciones que quieren comprobar y que pueden ser VERDADERO o FALSO, son entre 1 y 255.

FUNCIÓN SI

DESCRIPCIÓN

SINTAXIS

EJEMPLO

La función SI comprueba si se cumple ciertas condiciones:

Devuelve un valor si se evalúa como VERDADERO y si se evalúa como FALSO, otro valor.

  • =SI(Prueba_lógica;[Valor_si_verdadero];[Valor_si_falso])

·         Prueba_lógica: Es cualquier expresión o valor que pueda valorarse como FALSO o VERDADERO.

·         Valor_si_verdadero: si la prueba_lógica es VERDADERO, es el valor que se devolverá Si se omite, devolverá VERDADERO. Hasta siete funciones SI se puede anidar.

·         Valor_si_falso: Si la prueba_lógica es FALSO, es el valor que se devolverá. Si se omite, devolverá FALSO.

 

  • =SI(A1>=100;”Objetivo alcanzado”;”Objetivo no alcanzado”)

 

Funciones lógicas en Excel

FUNCIÓN SI.ERROR

DESCRIPCIÓN

SINTAXIS

EJEMPLO

Si la expresión es un error devuelve un valor y otro valor si no lo es.

 

  • SI.ERROR(valor; valor_si_error)

·         Valor (Obligatorio): Es cualquier expresión, valor o referencia.

·         Valor_si_error (Obligatorio): Es cualquier referencia, expresión o valor.

 

  • SI.ERROR(A1, “Error de cálculo”) = Error de cálculo

 

FUNCIÓN SI.ND

DESCRIPCIÓN

SINTAXIS

Si la expresión se convierte en #N/A devuelve el valor que específicas. Si no, devuelve el resultado de la expresión.

 

  • SI.ND(Valor, Valor_si_nd)

·         Valor (obligatorio): Es cualquier expresión, referencia o valor

·         Valor_si_nd (obligatorio): Es expresión, referencia o valor devuelto en caso de que el argumento Valor sea evaluado como el error #N/A.

FUNCIÓN VERDADERO

DESCRIPCIÓN SINTAXIS

RESULTADO DE LA FÓRMULA

Devuelve el valor lógico VERDADERO. VERDADERO() = VERDADERO

FUNCIÓN XO

DESCRIPCIÓN

SINTAXIS

Devuelve una “Exclusive Or” lógica de todos los argumentos.

 

  • XO(Valor_lógico_1, Valor_lógico_2, …)

·         Valor_lógico_1 (obligatorio): Pueden evaluarse como  VERDADERO o FALSO, también pueden ser referencias, matrices y valores lógicos; y son entre 1 y 254 condiciones que se requieren comprobar.

·         Valor_lógico_2 (opcional): Es el mismo resultado que el valor_lògico_1, es decir, son las condiciones que quieres probar de 1 a 254 que también pueden resultar VERDADERO o FALSO, así como valores lógicos, matrices o referencias.

Funciones lógicas en Excel

FUNCIÓN Y

DESCRIPCIÓN

SINTAXIS

EJEMPLO

Comprueba si todos los argumentos son VERDADEROS.

Si todos los argumentos son VERDADEROS, devuelve VERDADERO.

Si alguno de los argumentos es FALSO, devuelve FALSO.

 

·       Y(valor_lógico1, [valor_lógico2], …)

·       Valor_lógico1 (obligatorio): Primera condición a probar.

Pueden evaluarse como  VERDADERO o FALSO, también pueden ser referencias, matrices y valores lógicos; y son entre 1 y 255 condiciones que se requieren comprobar.

·       Valor_lógico2 (opcional): Condiciones adicionales a probar.

Pueden evaluarse como  VERDADERO o FALSO, también pueden ser referencias, matrices y valores lógicos; y son entre 1 y 255 condiciones que se requieren comprobar.

·         Y(VERDADERO, VERDADERO) = VERDADERO

·         Y(VERDADERO, VERDADERO, FALSO) = FALSO

 

 

 

Neetwork Business School es la escuela de negocios digitales más grande de hispanoamérica. ¡Más más de 2,000,000 de alumnos se han inscrito desde el 2018! Nuestro campus cuenta con más de 50 cursos y certificaciones (y contando). Inscríbete y lleva tus habilidades a otro nivel.
© 2022 Neetwork Online Business School B.V. Todos los derechos reservados.
crossmenu