Inscríbete en nuestro Máster Gratuito en Marketing Digital

100% en línea
80+ Horas
Horario Flexible
Con certificado
2M+ Alumnos

Categoría:
Autor: Jorge Rivero
Fecha: 22/07/2022

Suma las celdas que cumplen un determinado criterio con la función SUMAR.SI en Excel.

Una de las funciones básicas y necesarias para sumar valores de celdas que cumplen una determinada condición o criterio en una hoja de cálculo es “SUMAR.SI”.

Así como habíamos hecho una breve descripción de esta función en el artículo “Funciones básicas de Excel”. Te explicaremos en detalle de que se trata y como ejecutarla.

¿Qué es la función SUMAR.SI en Excel?

Esta función trabaja para establecer condiciones al momento de sumar ciertos valores, y obviar aquellas celdas que no son necesarias incluir en la operación, además de hacer el trabajo más rápido y ahorrarte tiempo.

Con esta función podrás sumar los “valores intervalo de un rango” que cumplan por supuesto con los criterios que especificaste previamente.

Puedes utilizar esta función si, por ejemplo, si tienes una tabla de datos y quieres calcular la suma de un conjunto de facturas de productos alimenticios registrados en tu tienda.

Supongamos que deseas saber la suma de las facturas que superen los 500 euros, por lo que utilizarías en tu hoja de cálculo, la siguiente expresión.

=SUMAR.SI(B2:B10;">500")

SUMAR.SI en Excel

En este caso, Excel calculará la suma de las celdas de las facturas que se encuentre dentro de la celda B2 hasta la celda B10 que superen el monto de 500 euros.

¿Cómo insertar la función?

Puedes hacerlo de varias formas.

La primera, escribiendo la función directamente o de forma manual en la barra de fórmulas, ubicado en la parte superior de la hoja de trabajo donde se encuentran las columnas.

Deberás escribir el signo igual (=), luego entre paréntesis, insertar el rango de valores a evaluar, que para el ejemplo anterior sería desde la celda B2 hasta la celda B10 (donde se encuentran los montos de las facturas), seguido de punto y coma (;) para entonces agregar entre comillas (“) el criterio que son los valores mayores a 500.

SUMAR.SI en Excel

Otra forma, es seleccionando la opción “Fórmulas” en el menú de tu libro de Excel, luego, “Insertar función”, seleccionar "SUMAR.SI" y por último "Aceptar".

SUMAR.SI en Excel

También en el menú de "Fórmulas", en el área de biblioteca de funciones, se encuentra la casilla de funciones "Matemáticas y trigonométricas", selecciónala y luego busca "SUMAR.SI" y haz clic.

SUMAR.SI en Excel

Para ambos casos, se abrirá un cuadro de diálogo llamado "Argumentos de función" donde aparece "Rango", "Criterio" y "Rango_suma".

SUMAR.SI en Excel

Argumentos de la función SUMAR.SI

Rango

Se refiere al rango o intervalos de celdas que será evaluado de acuerdo a los criterios, y es "obligatorio" insertar los valores en este campo.

La celda de cada rango deber ser:

  • Números
  • Nombres
  • Matrices
  • Referencias

Por supuesto que contengan números, ya que los textos o valores en blancos se ignorarán.

Criterio

También es obligatorio y describe a la condición que deberán cumplir las celdas que serán incluidas en la función.

El criterio puede estar en forma de:

  • Número (se sumarán solamente las celdas que sean iguales a dicho número)
  • Expresión (se podrá especificar alguna condición de mayor o menor que)
  • Referencia de celda
  • Texto (es porque probablemente necesitas que se establezca una condición de cierta columna donde sus datos son textos pero quieres hacer la sumatoria de otra columna que contiene valores numéricos)
  • Función

Por supuesto éstas deben determinar las celdas que va a sumar y también se pueden agregar caracteres como:

Un signo de interrogación (?) para que coincida con cualquier carácter individual

Un asterisco (*) para que coincida con cualquier secuencia de caracteres.

Escribe una tilde (~) antes del carácter, si deseas buscar un signo de interrogación o un asterisco real.

Los criterios pueden expresarse de la siguiente manera, por ejemplo: ">32", 32, B5, "3?", "tomates*".

Nota: 

  • Las comillas dobles no son necesarias si el criterio es numérico.
  • Si el criterio es cualquier texto o incluye símbolos matemáticos o lógicos entonces deberán estar entre comillas dobles (").

Rango_suma

Es opcional, y en este campo se incluyen las celdas que van a ser sumadas. Si esta casilla se omite, Excel sumará las celdas que hayas especificado en el "Rango".

Nota: Uno de los errores o resultados incorrectos que puede devolver la función SUMAR.SI es cuando se utiliza para hacer comparaciones de cadenas con más de 225 caracteres. (#¡VALOR!)

Ejemplos

Ejemplo 1

Tenemos una lista con ciertos valores y quieres sumar aquellas celdas que contenga un número específico, por ejemplo, quieres sumar todas las celdas que contengan el número 1. Para ello, la función quedaría representada de la siguiente manera:

=SUMAR.SI(B2:B11;1)

Entonces, el rango a evaluar son los datos de la columna B2 hasta la B11 y la condición es el número 1, dando como resultado que son 4 representantes.

SUMAR.SI en Excel

 

Recuerda que la función encuentra las celdas que contengan el número 1 y suma su valor. Es decir, las celdas B2, B4, B7 Y B10, cumplen con el criterio.

Para este mismo ejemplo se puede utilizar la condición "Expresión" (menor o mayor que). Por ejemplo, queremos saber cuál es la sumatoria de las celdas que contengan números mayores a 3. Entonces, la función se cumpliría de la siguiente manera:

=SUMAR.SI(B2:B11;">3")

SUMAR.SI en Excel

Entonces, la celda B5 y B8 cumplen con el criterio y se suman sus valores.

Ejemplo 2

Supongamos que quieres sumar las comisiones de los vendedores de acuerdo a los valores de vehículos por encima de los 200.000€.

SUMAR.SI en Excel

Entonces la fórmula corresponde así:

=SUMAR.SI(B2:B11;">200000";C2:C11)

Dando como resultado el monto de 270.000 euros para el total de comisiones. Si visualizas en el recuadro lateral comparamos de forma manual cada valor y coindice con los datos de los criterios incluidos en la fórmula.

Ejemplo 3

Para este ejemplo usaremos el criterio de texto y el tercer argumento de la función. Este argumento permite especificar un rango de suma diferente al seleccionado para el criterio, muy similar al ejemplo anterior, veamos.

Supongamos que deseas conocer la sumatoria de las comisiones a cancelar para la Vendedora de Nombre: Lucia.

Entonces la función se expresa de esta forma:

=SUMAR.SI(A2:A11;"Lucia";C2:C11)

SUMAR.SI en Excel

Arrojando como resultado que el total de las comisiones por ventas de la vendedora Lucia son 105.000 euros.

Ejemplo 4

Supongamos que trabajas para una ferretería y tienes una tabla especificada por categorías, producto y total de ventas por cada uno.

SUMAR.SI en Excel

Entonces deseas saber la siguiente información:

Sumar las ventas generadas para todos los productos pertenecientes a la categoría "Baño y Fontanería". La fórmula que corresponde es:

=SUMAR.SI(A4:A15;"Baño y Fontanería";C4:C15)

SUMAR.SI en Excel

También quieres sumar las ventas de aquellos productos que no poseen una categoría especificada, entonces la función se expresa de la siguiente manera.

=SUMAR.SI(A4:A15;"";C4:C15)

SUMAR.SI en Excel

Sumar las ventas de todos los productos que terminen en la letra O, entonces la función queda de la siguiente manera:

=SUMAR.SI(B4:B15;"*o";C4:C15)

SUMAR.SI en Excel

Esperamos que la próxima vez que debas realizar sumas en tu hoja de cálculo, utilices la función SUMAR.SI como todo un profesional.

Neetwork Business School es la escuela de negocios digitales más grande de hispanoamérica. ¡Más más de 2,000,000 de alumnos se han inscrito desde el 2018! Nuestro campus cuenta con más de 50 cursos y certificaciones (y contando). Inscríbete y lleva tus habilidades a otro nivel.
© 2022 Neetwork Online Business School B.V. Todos los derechos reservados.
crossmenu