Inscríbete en nuestro Máster Gratuito en Marketing Digital

100% en línea
80+ Horas
Horario Flexible
Con certificado
2M+ Alumnos

Categoría:
Autor: Jorge Rivero
Fecha: 18/07/2022

Prueba si una condición es verdadera o falsa con la Función SI en Excel

La función SI en Excel es una manera de agregar decisiones a tu hoja de cálculo, es decir, te prueba si una condición es verdadera o falsa. Además, ejecuta un conjunto de instrucciones específicas sustentadas en los resultados.

Una de las funciones más populares en Excel la cual le permite hacer comparaciones lógicas entre un valor y lo que espera es la función SI en Excel.

=SI (prueba_lógica, [valor_si_verdadero], [valor_si_falso])

La parte “SI” de la función es la prueba lógica y es donde se utilizan los operadores de comparación a fin de comparar dos valores, valga la redundancia.

Es importante mencionar que en la parte de comparación de la función, solo puede hacerse de dos valores, es decir, comparar dos valores. Estos pueden ser: números, una cadena de caracteres (valor de texto), hora o fecha, funciones que devuelven cualquiera de los valores anteriores o una referencia a cualquier otra celda de la hoja de cálculo que posea cualquiera de los valores anteriores.

Después de la función viene un punto y coma (;) y se incluyen los argumentos separados por otro punto y coma (;).

Esto quiere decir que, una declaración SI podrá tener dos resultados:

  1. La primera declaración es si su comparación es verdadera.
  2. La segunda declaración, le dirá a la función que mostrar o hacer si su comparación es falsa.

Si estas usando VERDADERO y FALSO, que Excel reconoce automáticamente y por defecto, al ingresar condiciones verdaderas o falsas en una declaración de la función SI en Excel deberás usar comillas alrededor de cualquier texto que desees devolver o mostrar.

Por ejemplo, al ingresar esta función, puedes probar si el valor de una celda específica es mayor a 700. Si el resultado lo es, entonces podrás hacer que la fórmula refleje o devuelva el texto con la palabras “Muy bien”, ahora, si el resultado no lo es, puedes hacer que la fórmula devuelva con “Pequeño”.

=SI(A2>700;"Muy bien";"Pequeño")

Función SI en Excel

Realmente, existen muchas condiciones con las que puedes ingresar en la función SI en Excel.

¿Dónde encontrar la Función SI en Excel?

En la barra de Menús, al seleccionar específicamente la opción de “Formulas” se desplegará una serie de herramientas relacionadas, en el lado izquierdo aparece un icono de función como este:

Al seleccionar la opción “Insertar función”, automáticamente se mostrará una ventana que te permitirá escoger entre diferentes funciones, para este caso, marcarás “SI” como tu función y luego “Aceptar”.

En otra ventana se mostrará los “Argumentos de función” para insertar la información.

Puedes hacerlo de dos formas:

  1. La primera, haciendo clic en el recuadro derecho la cual te permitirá escoger las celdas o los valores a comparar. En caso de que el resultado de la formula quieres que sea un numero descrito en la hoja de cálculo también lo puedes seleccionar.
  2. La segunda, escribiendo directamente en el recuadro en blanco, sin importar si el resultado quieres que sea en número, letra o palabras.

función SI en Excel

Este sería el paso a paso, sin embargo, lo puedes hacer directamente en la barra de fórmula en tu sección principal.

Compara valores en Excel.

Ejemplos de Uso de la función SI en Excel

Ejemplo simple

Hablamos de una empresa de exportación de alimentos.

Tenemos una tabla que muestra algunos rubros del sector alimenticio, los cuales se exportan a ciertos países. Supongamos que a cada país se le realizó un presupuesto y posteriormente ejecutaron un pedido y se les efectuaron las facturas correspondientes.

Pero, la compañía tiene por el mes de julio el 5% de descuento en su factura total si el monto facturado supera el monto presupuestado.

Entonces, queremos saber a cuales países les corresponde él % de descuento según el monto emitido en la factura.

Para ello, utilizamos la función SI en Excel de la siguiente manera:

=SI(E2>D2;"corresponde";"no corresponde")

Si “E2” es mayor a “D2”, de ser SI el resultado, entonces aparecerá la palabra “Corresponde”, si por el contrario, resulta ser menor, aparecerá la palabra “No corresponde”.

función SI en Excel

Luego de escribir los valores que quieres comparar, seguidamente va escrito entre comillas la palabra que quieras mostrar como resultado positivo o simplemente escribir “Si”, separado por un punto y coma y sin espacios, escribirás entre comillas la palabra que se mostrará en caso de ser negativo, o también podría ser “No”.

=SI(E2>D2;"SI";"NO")

Nota: Incluso puedes reflejar el resultado con un número.

=SI(D2="Sí";3;2)

Dice: SI(C2 = Sí; entonces devolver un 3; en caso contrario devolver un 2)

función SI en Excel

Ejemplo de ingreso de cálculos

En la función SI en Excel se pueden incluir diferentes cálculos, de acuerdo a los resultados de la comparación.

Supongamos que solicitaste un préstamo, y debes cancelar una tasa de interés acorde a las ventas que realices.

Tu función contendrá:

  • El monto de las ventas realizadas.
  • Estimación de préstamo
  • Tasa de interés

Entonces, si tus ventas son mayores a 2.250,00 €, la tasa de interés será del 5%, pero si las ventas son inferiores a dicho monto, la tasa de interés será del 10%.

  • El monto de las ventas realizadas, correspondientes a los datos de la columna “E”
  • Estimación de préstamo, en este caso sería igual a 2.250€
  • Tasa de interés: mayor a la estimación: 5%, menor a la estimación: 10%

La función SI, correspondería de la siguiente manera:

=SI(E2>2250;E2*5%;E2*10%)

función SI en Excel

Esto quiere decir que como las ventas descritas en la celda fueron mayores a 2250, las ventas se multiplicarían por el 5% y se reflejaría la tasa de interés a cancelar, que para este ejemplo, serían 214 €.

Otro ejemplo sería, si quieres calcular el impuesto adeudado de acuerdo a los ingresos reflejados en la columna A, tu prueba lógica compara el ingreso total en B2 para conocer si es mayor a €30.000, entonces tu función SI quedaría de la siguiente manera:

=SI(A2>30000;A2*7%;A2*10%)

Como A2  no fue mayor a 30000, la condición [valor_si_falso] calculará y devolverá el resultado.

Reflejando así: A2*10% que equivale a: 2.154,80€

función SI en Excel

En el lado de comparación de la función también se puede incrustar cálculos, por ejemplo.

Si deseas calcular la renta imponible que será del 60% de la renta total, puedes modificar la función SI anterior por la siguiente:

=SI(A2*60%>30000;A2*7%;A2*10%)

Esto quiere decir que Excel realizará el cálculo antes de compararlo con 30000

Nota: Es importante que tengas que presente que no debes escribir una coma (,) cuando ingreses números en miles, ya que, Excel dentro de una función interpreta una coma (,) como el final de un argumento.

Ejemplo de funciones anidadas dentro de una función SI

En esta función también puedes anidar o incrustar una función dentro de otra. Con ella puedes hacer cálculos avanzados y posteriormente realizar una comparativa de los resultados esperados con los reales.

Vamos con un ejemplo, supongamos que eres profesor y necesitas promediar las calificaciones de tu listado de estudiantes reflejadas en la columna E.

Entonces, dependerá de los resultados promedio de la clase si, superan los 50 puntos la función devolverá el texto “¡Genial!, pero si es inferior devolverá “Necesita esforzarse”.

Por lo tanto, tu función SI corresponde de la siguiente manera:

=SI(PROMEDIO(B3:D3)>15;"¡Genial!";"Necesita esforzarse")

función SI en Excel

Tiene múltiples ventajas aprender a utilizar esta función, pues, te ayuda a crear hojas de cálculos funcionales y dinámicas. Cuéntanos qué tal te fue con estos ejemplos, recuerda que la práctica hace al maestro; y si aun tienes dudas entonces alístate en el curso de Excel con nosotros.

Neetwork Business School es la escuela de negocios digitales más grande de hispanoamérica. ¡Más más de 2,000,000 de alumnos se han inscrito desde el 2018! Nuestro campus cuenta con más de 50 cursos y certificaciones (y contando). Inscríbete y lleva tus habilidades a otro nivel.
© 2022 Neetwork Online Business School B.V. Todos los derechos reservados.
crossmenu